E1.20 RDM (Remote Device Management) Protocol Forums  

Go Back   E1.20 RDM (Remote Device Management) Protocol Forums > RDM Developer Forums > RDM General Implementation Discussion

RDM General Implementation Discussion General Discussion and questions relating to implementing RDM in a product.

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old March 25th, 2015   #1
alvangee
Junior Member
 
Join Date: Jan 2015
Posts: 10
Default RDM Responder Tests and background DMX

Hi!
I have trouble running tests with DMX in background. The tests are run on Windows with VMware Player and Enttec DMX USB Pro Mk2. Tests are passed, but my LEDs are blinking during testing.
I think this is because some tests are sent not between DMX frames, but they are breaking DMX frame, i.e. not full 128 slots are sent, but sometimes only 2 or 3 while my Responder has four DMX slots.

And this is what happens. My responder gets some values for four slots (say, 0x55), then gets RDM request and process it (this takes sometimes up to 8-10 ms when I save parameters in flash and MCU doesn't respond due to disabled interrupts), then there's broken DMX frame with only 2-3 slots with higher value in this slots (say, 0x77) and Responder now has slots 0x77-0x77-0x55-0x55.

And here's the question: is this normal operation when RDM tests are run not between full DMX frames, but break them at random places?

The picture shows short DMX frame followed by RDM request and RDM response. dt shows BREAK to BREAK time (from DMX to RDM request) of 880 us, which less than 1204 minimum required BREAK-to-BREAK time from Table 6 of E1.11.


Update: Setting high start DMX address for Responder, like 120 or 125, shows that full 128 slots DMX frames are rarely received by Responder during RDM tests run. The blinking could be avoided by driving LEDs with received DMX values only when full set of four slots received, thus dropping short DMX frames completely - this works for me, but I still want to understand if this behavior of RDM tests is normal.

First video shows test with driving LEDs even when only one DMX slot is received - frequent blinking.
http://www.youtube.com/watch?v=nPb7AF3w044
Second video shows test with driving LEDs only when all four slots are received - no blinking and gradually increasing brightness.
https://youtu.be/F9yS93qfidE

Last edited by alvangee; March 25th, 2015 at 04:34 AM.
alvangee is offline   Reply With Quote
 

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
RDM Responder tests updated nomis52 RDM General Implementation Discussion 0 September 2nd, 2013 12:52 PM
Differences in current OLA RDM Responder tests? Robert040 RDM General Implementation Discussion 0 July 16th, 2013 06:51 AM
RDM Responder for low cost testing jpk__ RDM Marketplace Discussion 0 July 7th, 2013 09:00 PM
RDM Responder Tests are Ready nomis52 RDM General Implementation Discussion 2 March 17th, 2011 07:41 PM
Any RDM Responder Devices out there yet? sblair RDM Marketplace Discussion 8 September 20th, 2006 07:03 AM


All times are GMT -6. The time now is 05:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.