E1.20 RDM (Remote Device Management) Protocol Forums  

Go Back   E1.20 RDM (Remote Device Management) Protocol Forums > RDM Developer Forums > RDM General Implementation Discussion

RDM General Implementation Discussion General Discussion and questions relating to implementing RDM in a product.

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old November 17th, 2020   #1
FishFood6
Junior Member
 
Join Date: Nov 2020
Posts: 3
Default Discovery response format

I am having trouble with the Discovery Response signal and am unsure on how to fix it.

Current setup:
Iím sending an RDM Discovery signal with a DMXcat (controller) to a PSoC 4 controller (responder) with a rs485 shield to receive the data. The rs485 shield is in TX_CTRL mode, this would mean that the switch between TX and RX mode is made automatically by the shield. I am correctly receiving the Discovery signal on the responder but seem unable to return a response. I hardcoded the response in an array according to the standard in the E1.20 sheet. It consists of 8 Preamble bytes, 1 preamble separator byte, 12 EUID bytes and 4 encoded checksum bytes.

The Problem:
After sending the response I am unable to see any feedback as to what happened to this response. I am unsure what is causing the response to seemingly get lost. I have a couple of ideas as to what could be the issue but I donít know how Iíd be able to test if these ideas are true.

Possible solutions:
From what I can tell, the issue could be caused by a few things:
  • It could be that the response Iím sending is incomplete, but as far as I can tell from the E1.20 standard, this is not the case.
  • Another reason could be that I am incorrectly sending the array or it shouldnít be an array in the first place. Itís currently in an array of HEX values.
  • I do also still have my suspicions that the rs485 might not be correctly sending the data in automatic mode.
I think I might be able to properly solve this with a RDM sniffer but I am unable to find a proper one so far. The best one I found is the Enttecc RDM USB PRO (PN 70530), but it doesnít seem to be available anymore.

The main question:
The main questions are mostly centered on what could be an issue with sending the response and what is a good RDM sniffer.

Thanks in advance.
FishFood6 is offline   Reply With Quote
 

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Discovery Response Preamble prwatE120 RDM General Implementation Discussion 0 January 20th, 2007 12:22 AM


All times are GMT -6. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.