View Single Post
Old March 24th, 2015   #6
ericthegeek
Task Group Member
 
Join Date: Aug 2008
Posts: 358
Default

Quote:
Originally Posted by StephenYim View Post
RDM-100: CC 01 18 FF FF FF FF FF FF 00 00 00 00 00 00 25 01 00 00 00 10 00 03 00 07 18

RDM-100: CC 01 24 FF FF FF FF FF FF 00 00 00 00 00 00 26 01 00 00 00 10 00 01 0C 00 00 00 00 00 00 FF FF FF FF FF FE 0D 28
This is a broadcast Unmute followed by a discovery request. I didn't validate the checksums, but the overall structure looks correct

Quote:
Originally Posted by StephenYim View Post
My RDM Slave: FE FE FE FE FE FE FE AA AB 5D AE 5D AB 55 AB 55 AB 55 AB 55 AE 57 BB 57
This is a valid Discovery EUID for the UID 090C:01010101.

I changed one of my responders to have that UID, then captured its response during discovery. It matches the hexdump above, so based on this I can say your discovery response data is correct.

Quote:
Originally Posted by StephenYim View Post
And after these command & reply, nothing happen. No matter how many times and what I try, the result is the same, still disappointing. Please help me out.
The controller is unmuting, and then sending a discovery request for the entire UID range. But for some reason it is not accepting your response.

Based on my testing, your response data is correct. But there are still a lot of things that could be going wrong. Check timing: You may be responding too quickly, or waiting too long to respond. Another common problem is disabling the line driver when the UART TX interrupt occurs and not waiting until it has finished shifting out all 11 bits.
ericthegeek is offline   Reply With Quote