E1.20 RDM (Remote Device Management) Protocol Forums  

Go Back   E1.20 RDM (Remote Device Management) Protocol Forums > RDM Developer Forums > RDM General Implementation Discussion

RDM General Implementation Discussion General Discussion and questions relating to implementing RDM in a product.

Reply
 
Thread Tools Search this Thread Display Modes
Old March 10th, 2015   #1
sergeychk
Junior Member
 
Join Date: Apr 2014
Posts: 6
Default Answer for unsuspected queries

I test my own design fixture with RDM and I used Ecco Overled eSuit and received strange request for the responder for pid device info.
I used sniffer to capture protocol from start of discovery command till capture of this strange commands
In the response for mute command Control Field is 0x0000. (Not support Sub Devices)
But the controller has sent a request for responder Device_info for Sub_Devece = 0 and then for Sub_Devece = 17
The question is how the responder should answer if it does not support the Sub_Devices and controller ask device info for Sub_Device = 17 or other not supported Sub_Devices?
sergeychk is offline   Reply With Quote
Old March 10th, 2015   #2
hamish
Member
 
hamish's Avatar
 
Join Date: Apr 2009
Location: Dartmoor, Devon, England
Posts: 54
Send a message via Skype™ to hamish
Default

That's straight forward, respond with NR_SUB_DEVICE_OUT_OF_RANGE!
(Table A-17)
__________________
______________________________________________
Hamish Dumbreck
hamish is offline   Reply With Quote
Old March 10th, 2015   #3
prwatE120
Task Group Member
 
Join Date: Jun 2006
Posts: 180
Default

sergeychk

I would encourage you to attend the next RDM Plugfest here in the UK.

http://www.plasa.org/rdm/

Both Hamish and I will be in attendance and it is an ideal opportunity to get a great deal of testing done with the latest test tools. For example we will have a very detailed RDM responder test software package being trialled, and several of the RDMLabpacks which will allow you to evaluate the conformance of your Ecco Overled package.

Peter Willis
prwatE120 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.